+ Reply to Thread
Results 1 to 2 of 2

Thread: BA Falcon ute, running rich, black smoke, poor fuel economy

  1. #1
    lurch
    Join Date
    Jul 2007
    Location
    Melbourne
    Ride
    XD Fairmont Ghia
    Posts
    9

    Default BA Falcon ute, running rich, black smoke, poor fuel economy

    Hi All
    Long time member, first time poster (for memory).
    I need the experts in the room to help please!
    As the title suggests, my 02 BA Falcon Ute (5 speed), is running really rich, blowing black smoke and returning 16+L/100..
    Work done already as follows -

    NEW Fuel Pump
    NEW Fuel Filter
    NEW Fuel Pressure Regulator
    NEW Fuel Injectors
    NEW Centre Muffler (Red Back)
    NEW Exhaust manifold gasket
    NEW TB Gasket
    NEW Plenum Gasket
    NEW Intake Gasket
    NEW TPS
    NEW MAP Sensor
    NEW O2 Sensor
    NEW Air Filter
    Coil Packs and plugs less than 12 months old

    I am truly at my wits end on this!
    FORSCAN code reads P1132 - HSO211 Sensor Indicates Running Rich
    Low manifold pressure at T-MAP only
    Restricted air intake

    If anyone could shed some light on what the possibilities could be (could not seem to find any vacuum leaks any where with both 'Start ya Bastard' and degreaser).
    or at least be able to steer me to someone in either Epping VIC (and surrounding suburbs) or Bayswater Vic (and surrounding suburbs) that could help, BEERS ARE ON ME!
    Cheers
    Shane

  2. #2
    lurch
    Join Date
    Jul 2007
    Location
    Melbourne
    Ride
    XD Fairmont Ghia
    Posts
    9

    Default Re: BA Falcon ute, running rich, black smoke, poor fuel economy

    Forgot to mention -
    NEW PCV
    Plenum Cleaned

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts