+ Reply to Thread
Results 1 to 5 of 5

Thread: BA Falcon 04 LPG - Starts but doesn't run

  1. #1
    Junior Member
    Join Date
    Mar 2017
    Posts
    1

    Default BA Falcon 04 LPG - Starts but doesn't run

    Not sure if anyone can help diagnose a strange starting issue with my LPG BA Falcon.

    As soon as the engine starts, it does it's standard 1200 revs but then instead of dropping to it's idle revs and hold them, it looses all revs and shuts down. I've changed the following to rule out an ignition or vacuum problem;

    - New spark plugs

    - New coil packs

    - New PCV valve

    - Cleaned throttle body

    - Replace upper and lower air intake manifold gaskets

    - Replace the plenum as the rubber on mine deteriorated

    The only way I've managed to get it to idle and run as normal, is when I remove the plenum (the hard plastic part of the air intake) from the throttle body and hold the air filter against the throttle body. When I do this it starts and idles perfectly. As soon as I put the filter back into the air-box and connect the plenum to the throttle body and the rest of the air intake, it starts to play up again.

    Has anyone come across the same problem, or has a suggestion on why this might be happening.

    Thanks in advance!
    J

  2. #2
    Forum Veteran
    Join Date
    May 2006
    Location
    Fairfield, Sydney
    Ride
    XD XE ED & BA XR8
    Posts
    3,606

    Default Re: BA Falcon 04 LPG - Starts but doesn't run

    there must be some kind of vacuum leak somewhere. perhaps the plastic tubing is cracked somewhere or not sealing correctly. it must be fully airtight all the way to the filter. LPG is very sensitive to the slightest pressure change.
    Isn't it good when everything just works!!

  3. #3
    Junior Member
    Join Date
    Sep 2015
    Ride
    Ford BA s/wagon 2003
    Posts
    28

    Default Re: BA Falcon 04 LPG - Starts but doesn't run

    We used to have this problem on taxi's sometimes, we used to turn off the gas tap at the tank and then start the engine and let it run till it stops, then turn tap at tank back on and see what happens, i think sometimes they get an airlock in the line and doing this used to fix it.

  4. #4
    1 man disaster zone xy-transit's Avatar
    Join Date
    Sep 2008
    Location
    Ute Capital of the world
    Age
    39
    Ride
    24" hotfoot cruiser
    Posts
    1,280

    Default Re: BA Falcon 04 LPG - Starts but doesn't run

    What about the balance pipe from the converter to the airbox?

    Check both ends to see if they're connected properly and not cracked.
    plasma cutter + TIG + 2k paint= to infinity and beyond!



  5. #5
    Junior Member
    Join Date
    Sep 2015
    Ride
    Ford BA s/wagon 2003
    Posts
    28

    Default Re: BA Falcon 04 LPG - Starts but doesn't run

    My son has just had this problem with his 2009 BF and it was caused by a faulty crank angle sensor, he had replaced everything you had replaced and as he had a 2004 BA he replaced the crank angle sensor from it, he said you could feel the differance in the strength of the magnet. This does not show on a scanner as the manual say's there is no fault code for it.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts