+ Reply to Thread
Results 1 to 5 of 5

Thread: FG 09 XR6 - Knocking sound

  1. #1
    Junior Member
    Join Date
    May 2016
    Ride
    Ford FG XR6 2009
    Posts
    6

    Default FG 09 XR6 - Knocking sound

    Hi all,
    Lately I have been hearing a slight knock/cracking sound in the front end of the car only sometimes when going over bumps or when turning the steering wheel left and right at slow speeds.
    Anyone else ever had this issue or know what it could be? I've been told possibly a loose ball joint.
    Last edited by sirxr6; 08-07-2016 at 10:41 AM.

  2. #2
    Forum Regular
    Join Date
    Jul 2011
    Location
    hoppers crossing
    Age
    58
    Ride
    2009 fg g6e turbo
    Posts
    79

    Default Re: FG 09 XR6 - Knocking sound

    had a knocking sound in my g6e took it back to dealer [under warranty] turned out the control arm bush,s were shot, they replaced both upper and lower. as it was under warranry they replaced the complete arms not just the bushs

  3. #3
    Forum Veteran
    Join Date
    May 2006
    Location
    Fairfield, Sydney
    Ride
    XD XE ED & BA XR8
    Posts
    3,604

    Default Re: FG 09 XR6 - Knocking sound

    sway bar links too do the similar noise.
    Isn't it good when everything just works!!

  4. #4
    Junior Member
    Join Date
    May 2015
    Ride
    2008 FG XR6 N/A
    Posts
    4

    Default Re: FG 09 XR6 - Knocking sound

    I've got mine in at a mechanic for a very similar sounding issue at the moment. I've had the sway bar links replaced before when I had a similar sound, that fixed the issue for me. This time you can hear a knock over bumps, and there's a crunch/cracking sound when turning hard right, mainly when brakes are applied (maybe this puts more stress on whatever part it is?). I'll let you know what they say for me.



  5. #5
    Junior Member
    Join Date
    Apr 2005
    Location
    Melbourne
    Ride
    TC cortina/G6E TURBO
    Posts
    16

    Default Re: FG 09 XR6 - Knocking sound

    I also had a knocking sound over bumps at times turned out to be the strut, It didn,t have any fluid loss, on a bounce test it was fine , sounded like (old school) a ball joint worn/loose ball.
    If your vehicle has over 100K very possible. Hope it helps cheers..

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts