+ Reply to Thread
Results 1 to 6 of 6

Thread: Cold start engine knock

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Ride
    ba xt falcon
    Posts
    16

    Default Cold start engine knock

    Hi everyone. I have a 2003 BA with 145000 ks. There is a knock in the engine on a cold start up which goes after a few seconds. It can be quite loud sometimes and sometimes it's not there at all. My local mechanic thinks it may be an oil drain back issue where there is no oil in the top until pressure builds up. Are these engines fitted with a oil valve that may be faulty and allowing oil to completely drain from the top end. Thanks for any help.

  2. #2
    Junior Member
    Join Date
    May 2010
    Ride
    xr8 ute mkII manual
    Posts
    2

    Default Re: Cold start engine knock

    try a genuine oil filter i have read somewhere that has fixed the cold start rattle in another blokes BA. must hold the pressure up the top end somehow instead of letting it drain through, worth a shot maybe?

  3. #3
    Forum Regular
    Join Date
    Mar 2010
    Ride
    BA FALCON
    Posts
    104

    Default Re: Cold start engine knock

    i have 2005 BA only70K, had a rattle noise when starting cold engine, replaced noisy idler pulley, noise gone ( if you listen to idler pulley you can tell if the bearing is making a grinding noise, had mind replaced under warranty, but replacement pulley assy should only cost approx $40 )

  4. #4
    Junior Member
    Join Date
    Mar 2009
    Ride
    BA RTV UTE V8
    Posts
    10

    Default Re: Cold start engine knock

    Hi Hessian,
    what engine have you got, if it's a V8 it could be cam phaser sprockets.
    Bryan.



  5. #5
    Forum Veteran
    Join Date
    May 2006
    Location
    Fairfield, Sydney
    Ride
    DF LTD 5.0 & BA XR8
    Posts
    3,567

    Default Re: Cold start engine knock

    all oil filters have that drainback valve. some genuine 6cyl oil filters are poorly made. the center hole where the thread is, is not in the centre.... be carefull.

    are u using the right oil?
    Isn't it good when everything just works!!

  6. #6
    Junior Member
    Join Date
    Jun 2009
    Ride
    ba xt falcon
    Posts
    16

    Default Re: Cold start engine knock

    Hi all. Thanks for the responses. The engine is a 6 cylinder. I have tried various oil filters and the problem remains. I am also using the correct grade of oil. I no longer drive the vehicle. It just sits in the driveway like a big white elephant. Thanks everyone for all the suggestions. I am now looking to trade the car in. After 36 years of driving Fords this will certainly be my last.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts