+ Reply to Thread
Results 1 to 17 of 17

Thread: Fiesta problem - Speedo drops to Zero intermittantly ?

  1. #1
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Fiesta problem - Speedo drops to Zero intermittantly ?

    Bought my late '04 Fiesta bought new in '05 has had an intermittant problem for a while where the Speedo needle drops to Zero for 10 to 30 seconds sometimes weeks apart or sometimes each time I drive.

    Note - the ODO also stops during this time.

    Anyone know of a similar problem affecting Fiesta or have an idea where to start looking ?

  2. #2
    Junior Member
    Join Date
    May 2010
    Ride
    2006 WQ Fiesta
    Posts
    4

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Gidday,
    Noted your post, my 06 fiesta is doing the same thing. I put a post up last week describing my problem. Have you had any luck fixing the problem?

  3. #3
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Quote Originally Posted by pal65 View Post
    Gidday,
    Have you had any luck fixing the problem?
    I believe so,

    After being in the local ( servicing ) dealer a few times with them trying different things but no fix then searching out on UK Ford sites found it's a semi common problem with 02 to 04 1.6 Focus and Fiestas I told them not to diagnose the fault any further and just replace the Speedo sensor that sits behind the engine / gearbox housing and insisted they give me the old one.

    Not to say it's the same issue as yours but 4 weeks later have not had any further problems with the speedo flickering off and on again so think the issue sorted.
    Last edited by John451; 17-05-2010 at 05:47 PM.

  4. #4
    Junior Member
    Join Date
    Aug 2010
    Ride
    kristinthomas21
    Posts
    5

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    First, make sure the radio PIN. You will need it later to activate the radio. (If not, can be obtained from local Ford dealer with VIN and proof of ownership, Rego documents are good) Disconnect the positive and negative wires from the battery. Connect the battery two children together and hold for 30 seconds. Reconnect the battery positive cable, then the negative cable. The engine management reload the default values back into memory. counter is reset and the radio code must be entered again.



  5. #5
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Just an update, 3 months on the Speedo sensor change completely resolved the Speedo drops to Zero fault.

  6. #6
    Junior Member
    Join Date
    May 2010
    Ride
    2006 WQ Fiesta
    Posts
    4

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Update on my Fiesta problem. Thought I'd give Ford a shot at diagnosing/fixing my problem. Was quoted $90 to have it put on the computer at my local Ford dealer. Dropped it off and explained the problem, was told they would put it on the computer and diagnose but not fix without authorisation. Went to pick it up 4 hrs later and handed a bill for $250. When questioned, dealer explained they could not find the problem but noticed that the computer had missed 2 updates, so they updated it at NO CHARGE fantastic. When pushed further on the bill being a lot higher than quoted was told $90 was the diagnostic fee not including labour or GST, so add labour & GST to my $90 gives me a bill for $250.
    Drove away very angry. The next day the problem returned. Rang Dealer and was informed that he would need the car for a few days to 'maybe' find the problem. Told him he would never see the car again!
    Went to my local mechanic and requested that he replace the speed sensor as suggested by John451. Cost $150 including labour and the car has run perfectly since (6 weeks now).
    I thought that in 2010 with the computer age and information sharing that ALL Ford dealers would have some idea of this problem. How nieve of me. It seems it's all about the almighty dollar and not customer service.
    Once again Thankyou John451.

  7. #7
    Locum Moderator docjames's Avatar
    Join Date
    Aug 2004
    Location
    Melbourne (brrrrrrr)
    Ride
    2014 VF SSV Redline
    Posts
    5,004

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    This is sadly a common report of Ford delaers. I really wish head office would take note - this is really holding Ford back.

    On the plus side, glad the Fiesta is running well again!
    Current Rides:
    2014 VF Commodore SSV Redline Manual
    2013 VW Touareg 180TDI

    Still, I've owned plenty of Fords before......

  8. #8
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Update - 23 months on still no further speedo problems so believe issue sorted.

  9. #9
    Forum Regular
    Join Date
    Apr 2012
    Location
    Albury
    Ride
    V8 range rover
    Posts
    69

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Is a fault I've seen a couple of times on uk fiestas, if the morons at your dealer had any sense they would of looked on the tsb part of etis.

    Removing battery terminals and carrying out an ecu hard reset will never work for an issue like this, for windows and electric mirrors being out of sync yes but not for anything else.

  10. #10
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Quote Originally Posted by Fonfe View Post
    Is a fault I've seen a couple of times on uk fiestas, if the morons at your dealer had any sense
    Too right they are, was not at all happy after my servicing FORD dealer had " Diagnosed " it twice previously prior to the car suddenly stopping stranding me late night on the way home from work. After the NRMA Trunk dropped it off at the Dealer I asked them had they been in contact with FORD Head quarters as they said they would they and said they also had and they also never heard of this problem before.

    After getting the car working again by flashing my ECU...( yet again ) they informed me they may have to replace the ECU at my expense if it stopped again...Literally 15 minutes searching the UK Focus / Fiesta Forum found the Speed Sensor was a common fault in my models years.

    Was madder after I'd ordered the " Speed Sensor " for them to replace and they yet again asked me if they should diagnose further before replacing it not believing my UK Forum print outs.

    7 years ownership with only the water pump and thrust bearing failing find I still love driving the car but no wonder people lose faith in FORD Servicing...

  11. #11
    Junior Member
    Join Date
    May 2010
    Ride
    2006 WQ Fiesta
    Posts
    4

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Good to here that you are still travelling problem free. I have also been problem free since replacing the speed sensor as suggested. Just clicked over 250 000km and I still love driving my baby Ford.
    The only minor hiccup, clutch pedal went to floor a couple of months ago - discovered a small spring type washer had dislodged from locating pin leaving the pedal unattached. Went to Ford to buy a new washer (how hard could that be?) In my area we have 2 Ford dealerships both with a servicing department, both owned by the same company. Dealer 1 politely informed me that he had never heard of this washer coming off and that he could not sell it on its own, I would have to buy a complete clutch pedal assembly at about $200. Went to dealer 2 out of curiosity, the service department there said that they had received a fax from head office a few months ago about this very thing, a 2 minute search of paperwork and the fax was located and the washer was sold to me for less than $5.
    Just helps to reinforce my lack of faith in Fords after sales help.

  12. #12
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Quote Originally Posted by pal65 View Post
    The only minor hiccup, clutch pedal went to floor a couple of months ago - discovered a small spring type washer had dislodged from locating pin leaving the pedal unattached.
    Thanks for the tip will keep an eye for that, had sprayed that area with Silicon spray about a year ago when it went a bit squeaky but has been quite ever since.

  13. #13
    Junior Member
    Join Date
    Apr 2013
    Ride
    Fiesta
    Posts
    1

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Hi there,
    Same problem except worse... my engine stops on some of the occasions that the speedo dies! A quick flick of the key of and on and the engine restarts but generally not the speedo. It's one of a long list of issues with this fiesta, which drives great but was built poorly :-). Honestly, should have bought a Mazda 2 but the new shape wasn't out when I was needing to buy.
    Thanks to others here for their clues!

  14. #14
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Quote Originally Posted by hogey74 View Post
    Hi there,
    Same problem except worse... my engine stops on some of the occasions that the speedo dies! A quick flick of the key of and on and the engine restarts but generally not the speedo. It's one of a long list of issues with this fiesta, which drives great but was built poorly :-). Honestly, should have bought a Mazda 2 but the new shape wasn't out when I was needing to buy.
    Thanks to others here for their clues!
    Can't see your build year from your post but for my issue in the year models '02 to '06 the gearbox speedo sensor failure was a well known cause of my troubles in UK Fiesta forums if NOT by my Servicing Ford Dealer or Ford Australia and appear very similar to yours, all problems went away fully since it was replaced 3 years ago and 8.5 years of ownership I still love driving my little German made Fiesta and never want it to wear out so get it fixed and be happy.
    Last edited by John451; 30-04-2013 at 10:01 AM.

  15. #15

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Probably just need the speedometer replaced or repaired.
    Last edited by cardozosula; 05-07-2013 at 09:34 PM.

  16. #16
    Junior Member
    Join Date
    May 2010
    Ride
    2006 WQ Fiesta
    Posts
    4

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Updated my WQ 2006 Fiesta in November 2012 to a new WT 2012 model. My WQ had 280 000km on it, the engine had become a little noisy and the clutch was starting to go.
    What a disappointment! The WT is nowhere near as good as the WQ. Hang on to your earlier models as long as you can.

  17. #17
    Junior Member
    Join Date
    Sep 2009
    Ride
    Ford Fiesta LX 1.6 M
    Posts
    25

    Default Re: Fiesta problem - Speedo drops to Zero intermittantly ?

    Quote Originally Posted by pal65 View Post
    The WT is nowhere near as good as the WQ. Hang on to your earlier models as long as you can.
    Know what you mean, recently told a work mate my near 10yro old Fiesta is still running brilliantly and hoping it never wears out because there's nothing on the market in its class at the that I'd prefer, also being manual think its the perfect car for my daughter to learn to drive later this year.

+ Reply to Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts