PDA

View Full Version : ef falcon miss



ept67
15-03-2010, 09:44 PM
my 94 ef falcon has intermitten miss when warm,no rough idiling or anything else suspect.could anyone give me any sugestions.

bennomate
16-03-2010, 12:57 AM
Mine has the same thing.. its almost smooth apart from a slight bump here and there? i think there was a long post somewhere about a bloke with the same issue i beleive he got his fuel injectors reco'd and a new ECU and it fixed the problem you could try searching for the thread it was in this section.

I havent fixed it but ive tried a new TPS sensor which didnt make a difference, i have cleaned my ISC solenoid and throttle body with no luck, regapped the spark plugs, run petrol injector cleaner through it, looked for a leak in the inlet manifold, pulled the rocker cover off and inspected the tappets and valves with nothing, and run high octane petrol. Id put a bottle of fuel injector cleaner in it anyway cos its cheap and may make your economy better and has a chance of fixing it. If you find the issue please post it up as im sure others have this problem to and i personally would be interested to know. Goodluck!

Cheers

ceebee51
06-04-2010, 08:17 PM
my ef used to miss under load only, and when warm, was the plug leads.
the el xr6 i have now has like a miss only at idle in neutral, strange things ,cars.

ept67
31-05-2010, 08:59 AM
Hey guys,thanks for your input. I have changed leads,no change. Then i changed the cam angle sensor thing where dissy usually is and presto problem seems to have dissapeared.